Cisco IAD2432 and PRI T1

We have a Cisco IAD2432-24FXS in use, we are currently using the FXS analog ports to provide analog modem lines for our ISP dial-in lines and for general use.

Now that we have our 3com/USR Total Control running, we need to feed it with a PRI or channelized T1 (these are similar but slightly different).

the IAD2432 has two T1 ports onboard, so I’m now trying to see if these are usable for this purpose. The first problem I had was that the T1 interfaces didn’t show up in sh int or sh controllers , thankfully Alfredrb already got this working on the same hardware and shared his config.

The first key is to set card type t1 1 in the config, this sets the T1 card to .. T1 mode, rather than E1. With this done, I was then able to set isdn at the top level config

Thanks Alfred for sharing your config:

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CiscoIAD
!
boot-start-marker
boot-end-marker
!
card type t1 1
logging message-counter syslog
!
no aaa new-model
clock timezone EST -4
network-clock-participate T1 1/0
network-clock-participate T1 1/1
ip source-route
!
!
ip cef
ip domain name rbnet.arpa
ip name-server 10.0.0.1
!
ip dhcp pool VOICE
   network 172.0.10.0 255.255.255.0
   default-router 172.0.10.1
   option 150 ip 172.0.10.1
!
!
no ipv6 cef
multilink bundle-name authenticated
isdn switch-type primary-ni
!
!
!
voice service voip
 fax protocol cisco
 no fax-relay sg3-to-g3
 modem passthrough nse codec g711ulaw
 sip
  no call service stop
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
archive
 log config
  hidekeys
!
!
controller T1 1/0
!
controller T1 1/1
 clock source internal
 cablelength short 133
 pri-group timeslots 1-24
!
!
!
!
!
interface Loopback0
 no ip address
!
interface BRI0/0
 no ip address
 isdn switch-type basic-ni
 isdn timer T309 30000
 isdn protocol-emulate network
 isdn tei-negotiation first-call
 isdn point-to-point-setup
 isdn layer1-emulate network
 isdn incoming-voice voice
 isdn supp-service name calling
 isdn skipsend-idverify
!
interface FastEthernet0/0
 ip address 10.0.100.30 255.0.0.0
 duplex full
 speed auto
!
interface BRI0/1
 no ip address
 isdn switch-type basic-ni
 isdn tei-negotiation first-call
 isdn point-to-point-setup
!
interface FastEthernet0/1
 ip address 172.0.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 ip address 172.10.10.1 255.255.255.0
!
interface Serial1/1:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bchan-number-order ascending round-robin
 no cdp enable
!
no ip http server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
!
!
!
control-plane
!
!
!
voice-port 0/0
!
voice-port 0/1
!
!
voice-port 1/1:23
 translation-profile incoming prefix
 no vad
!
voice-port 2/0
!
voice-port 2/1
!
voice-port 2/2
!
voice-port 2/3
!
voice-port 2/4
!
voice-port 2/5
!
voice-port 2/6
!
voice-port 2/7
!
voice-port 2/8
!
voice-port 2/9
!
voice-port 2/10
!
voice-port 2/11
!
voice-port 2/12
!
voice-port 2/13
!
voice-port 2/14
!
voice-port 2/15
!
voice-port 2/16
!
voice-port 2/17
!
voice-port 2/18
!
voice-port 2/19
!
voice-port 2/20
!
voice-port 2/21
!
voice-port 2/22
!
voice-port 2/23
!
!
!
!
dial-peer voice 20 voip
 description 10 Digit Dial
 destination-pattern ..........T
 session protocol sipv2
 session target sip-server
 dtmf-relay sip-kpml
 codec g711ulaw
!
dial-peer voice 30 voip
 description 11 Digit Dial
 destination-pattern ...........
 session protocol sipv2
 session target sip-server
 dtmf-relay sip-kpml
 codec g711ulaw
!
dial-peer voice 100 voip
 description Catch All Dial
 destination-pattern .T
 session protocol sipv2
 session target sip-server
 dtmf-relay sip-kpml
 codec g711ulaw
!
dial-peer voice 10 voip
 description Extenstion Dial
 destination-pattern ....T
 session protocol sipv2
 session target sip-server
 dtmf-relay sip-kpml
 codec g711ulaw
!
dial-peer voice 2000 pots
 destination-pattern 7000
 port 2/0
 authentication username 7000 password bla
!
dial-peer voice 2002 pots
 destination-pattern 7002
 port 2/2
 authentication username 7002 password bla
!
dial-peer voice 5000 pots
 destination-pattern 50110
 direct-inward-dial
 port 1/1:23
!
dial-peer voice 60110 pots
 destination-pattern 60110
 direct-inward-dial
 port 0/0
!
dial-peer voice 60120 pots
 destination-pattern 60120
 port 0/1
!
!
sip-ua
 registrar ipv4:192.168.1.91:5060 expires 3600
 sip-server ipv4:192.168.1.91
!
!
telephony-service
 max-ephones 5
 max-dn 5
 ip source-address 172.0.10.1 port 2000
 auto assign 4 to 6
 auto assign 1 to 5
 time-zone 12
 max-conferences 4 gain -6
 transfer-system full-consult
 create cnf-files version-stamp 7960 Aug 12 2024 16:21:02
!
!
ephone-dn  1
 number 101
!
!
ephone  1
 mac-address E804.6212.8944
 type 7962
 button  1:1
!
!
!
line con 0
line aux 0
line vty 0
 password 5377
 login
line vty 1 4
 password 5377b
 login
!
ntp server 192.168.1.1
ntp server 129.6.15.28
end

Further reference: https://www.cisco.com/en/US/docs/routers/access/2400/2420/software/configuration/guide/2420sw.html

and https://www.cisco.com/c/en/us/td/docs/routers/access/iad2400/2430/software/configuration/guide/sw_conf.pdf

To top